<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" 
 xmlns:fb="http://ogp.me/ns/fb#">
<head>
	<meta name="description" lang="en" content="All about Ghana, Africa, World - Latest News, Entertainment News in Ghana, Celebrity Gossips, Fashion, Music Videos, Events, Relationship, Lifestyle Business, Agribusiness, Economy, Sports, Football in Ghana, Basketball, Tennis, Technology, Gaming, Phones, Opinions">
    <meta name="keywords" content="Top Stories, k-pop, BTS, BlackPink, Headlines in Ghana, News in ghana, Latest in Ghana, menzgold, GhBase, GhPage, GhanaCelebrities, CelebritiesBuzz, Shatta Wale, Sarkodie, Stonebwoy, joyfm, joyonline, myjoyonline, myjoyonline.com, ghana, ghanaweb, ghana web, yen, pulse ghana, accra, ghana news, ghana business, ghana sports, ghana entertainment, ghana politics, ghana health, ghana elections, ghana tourism, ghana lifestyle and world news homepage, banking, finance, insurance, oil, gas, presidential and parliamentary elections, ghana, elections 2020, elections 2016, ghana votes, ghana decides 2020, president, ndc, npp, ppp, cpp, government, john mahama, nana akufo addo"/>
    <meta charset="UTF-8" />	
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta name="facebook-domain-verification" content="ywmoupdixcinv7ej6wj4e0wamzx32d" />
	<link rel="pingback" href="https://plugtimes.com/xmlrpc.php" />	
	<link rel="profile" href="http://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="CE8q_B0Ps_f9X9bhlN7Yq5tZrss5EmpViWo_3Q5A4Cc" />
<meta name="msvalidate.01" content="9E58A42BD8F034AB930A9B659DB9BF22" />

	<!-- This site is optimized with the Yoast SEO plugin v18.4.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Morris Chestnut Receives Star on Hollywood Walk of Fame &ndash; PlugTimes.com</title>
	<meta name="description" content="Morris Chestnut earns a Hollywood Walk of Fame star following years of remarkable performance in film. The star presentation to the Hollywood" />
	<link rel="canonical" href="https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Morris Chestnut Receives Star on Hollywood Walk of Fame &ndash; PlugTimes.com" />
	<meta property="og:description" content="Morris Chestnut earns a Hollywood Walk of Fame star following years of remarkable performance in film. The star presentation to the Hollywood" />
	<meta property="og:url" content="https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/" />
	<meta property="og:site_name" content="PlugTimes.com" />
	<meta property="article:publisher" content="https://facebook.com/PlugTimesHQ" />
	<meta property="article:author" content="https://facebook.com/PlugTimesHQ" />
	<meta property="article:published_time" content="2022-03-26T21:48:18+00:00" />
	<meta property="article:modified_time" content="2022-03-26T21:48:20+00:00" />
	<meta property="og:image" content="https://plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="474" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:description" content="Morris Chestnut earns a Hollywood Walk of Fame star following years of remarkable performance in film. The star presentation to the Hollywood" />
	<meta name="twitter:creator" content="@PlugTimesHQ" />
	<meta name="twitter:site" content="@PlugTimesHQ" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="PlugTimes.com" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="1 minute" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://plugtimes.com/#organization","name":"PlugTimes.com","url":"https://plugtimes.com/","sameAs":["https://facebook.com/PlugTimesHQ","https://instagram.com/PlugTimesHQ","https://www.youtube.com/c/PlugTimesTV","https://twitter.com/PlugTimesHQ"],"logo":{"@type":"ImageObject","@id":"https://plugtimes.com/#logo","inLanguage":"en-US","url":"https://i1.wp.com/plugtimes.com/wp-content/uploads/2019/07/PlugTimes-Logo-main.jpg?fit=3500%2C3500&ssl=1","contentUrl":"https://i1.wp.com/plugtimes.com/wp-content/uploads/2019/07/PlugTimes-Logo-main.jpg?fit=3500%2C3500&ssl=1","width":3500,"height":3500,"caption":"PlugTimes.com"},"image":{"@id":"https://plugtimes.com/#logo"}},{"@type":"WebSite","@id":"https://plugtimes.com/#website","url":"https://plugtimes.com/","name":"PlugTimes.com","description":"Latest Ghana News, Entertainment, Business, Sports, Technology","publisher":{"@id":"https://plugtimes.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://plugtimes.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star.jpg?fit=800%2C474&ssl=1","contentUrl":"https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star.jpg?fit=800%2C474&ssl=1","width":800,"height":474,"caption":"Morris Chestnut hollywood walk of fame star"},{"@type":"WebPage","@id":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/#webpage","url":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/","name":"Morris Chestnut Receives Star on Hollywood Walk of Fame &ndash; PlugTimes.com","isPartOf":{"@id":"https://plugtimes.com/#website"},"primaryImageOfPage":{"@id":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/#primaryimage"},"datePublished":"2022-03-26T21:48:18+00:00","dateModified":"2022-03-26T21:48:20+00:00","description":"Morris Chestnut earns a Hollywood Walk of Fame star following years of remarkable performance in film. The star presentation to the Hollywood","breadcrumb":{"@id":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/"]}]},{"@type":"BreadcrumbList","@id":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://plugtimes.com/"},{"@type":"ListItem","position":2,"name":"Morris Chestnut Receives Star on Hollywood Walk of Fame"}]},{"@type":"Article","@id":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/#article","isPartOf":{"@id":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/#webpage"},"author":{"@id":"https://plugtimes.com/#/schema/person/85ee0b2f2d670bde043bb01508f92ab9"},"headline":"Morris Chestnut Receives Star on Hollywood Walk of Fame","datePublished":"2022-03-26T21:48:18+00:00","dateModified":"2022-03-26T21:48:20+00:00","mainEntityOfPage":{"@id":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/#webpage"},"wordCount":164,"publisher":{"@id":"https://plugtimes.com/#organization"},"image":{"@id":"https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/#primaryimage"},"thumbnailUrl":"https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star.jpg?fit=800%2C474&ssl=1","keywords":["Hollywood Walk of Fame","Morris Chestnut"],"articleSection":["Entertainment"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://plugtimes.com/#/schema/person/85ee0b2f2d670bde043bb01508f92ab9","name":"PlugTimes.com","image":{"@type":"ImageObject","@id":"https://plugtimes.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=96&d=mm&r=g","caption":"PlugTimes.com"},"description":"Latest Ghana News, Entertainment, Business, Sports, Technology | Celebrity Gossip, Music, Movies, Dance, Fashion, Events and more from Ghana, Africa, and the World","sameAs":["https://plugtimes.com","https://facebook.com/PlugTimesHQ","https://instagram.com/PlugTimesHQ","https://twitter.com/PlugTimesHQ"],"url":"https://plugtimes.com/author/plugtimesonline/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="PlugTimes.com &raquo; Feed" href="https://plugtimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="PlugTimes.com &raquo; Comments Feed" href="https://plugtimes.com/comments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/plugtimes.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.9.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='wp-block-library-theme-inline-css' type='text/css'>
.wp-block-audio figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-audio figcaption{color:hsla(0,0%,100%,.65)}.wp-block-code>code{font-family:Menlo,Consolas,monaco,monospace;color:#1e1e1e;padding:.8em 1em;border:1px solid #ddd;border-radius:4px}.wp-block-embed figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-embed figcaption{color:hsla(0,0%,100%,.65)}.blocks-gallery-caption{color:#555;font-size:13px;text-align:center}.is-dark-theme .blocks-gallery-caption{color:hsla(0,0%,100%,.65)}.wp-block-image figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-image figcaption{color:hsla(0,0%,100%,.65)}.wp-block-pullquote{border-top:4px solid;border-bottom:4px solid;margin-bottom:1.75em;color:currentColor}.wp-block-pullquote__citation,.wp-block-pullquote cite,.wp-block-pullquote footer{color:currentColor;text-transform:uppercase;font-size:.8125em;font-style:normal}.wp-block-quote{border-left:.25em solid;margin:0 0 1.75em;padding-left:1em}.wp-block-quote cite,.wp-block-quote footer{color:currentColor;font-size:.8125em;position:relative;font-style:normal}.wp-block-quote.has-text-align-right{border-left:none;border-right:.25em solid;padding-left:0;padding-right:1em}.wp-block-quote.has-text-align-center{border:none;padding-left:0}.wp-block-quote.is-large,.wp-block-quote.is-style-large,.wp-block-quote.is-style-plain{border:none}.wp-block-search .wp-block-search__label{font-weight:700}.wp-block-group:where(.has-background){padding:1.25em 2.375em}.wp-block-separator{border:none;border-bottom:2px solid;margin-left:auto;margin-right:auto;opacity:.4}.wp-block-separator:not(.is-style-wide):not(.is-style-dots){width:100px}.wp-block-separator.has-background:not(.is-style-dots){border-bottom:none;height:1px}.wp-block-separator.has-background:not(.is-style-wide):not(.is-style-dots){height:2px}.wp-block-table thead{border-bottom:3px solid}.wp-block-table tfoot{border-top:3px solid}.wp-block-table td,.wp-block-table th{padding:.5em;border:1px solid;word-break:normal}.wp-block-table figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-table figcaption{color:hsla(0,0%,100%,.65)}.wp-block-video figcaption{color:#555;font-size:13px;text-align:center}.is-dark-theme .wp-block-video figcaption{color:hsla(0,0%,100%,.65)}.wp-block-template-part.has-background{padding:1.25em 2.375em;margin-top:0;margin-bottom:0}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/5.9.2/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/5.9.2/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='cookie-law-info-css'  href='https://plugtimes.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='cookie-law-info-gdpr-css'  href='https://plugtimes.com/wp-content/plugins/cookie-law-info/public/css/cookie-law-info-gdpr.css' type='text/css' media='all' />
<link rel='stylesheet' id='theiaPostSlider-css'  href='https://plugtimes.com/wp-content/plugins/theia-post-slider-premium/dist/css/font-theme.css' type='text/css' media='all' />
<style id='theiaPostSlider-inline-css' type='text/css'>


				.theiaPostSlider_nav.fontTheme ._title,
				.theiaPostSlider_nav.fontTheme ._text {
					line-height: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button,
				.theiaPostSlider_nav.fontTheme ._button svg {
					color: #f08100;
					fill: #f08100;
				}
	
				.theiaPostSlider_nav.fontTheme ._button ._2 span {
					font-size: 48px;
					line-height: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button ._2 svg {
					width: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button:hover,
				.theiaPostSlider_nav.fontTheme ._button:focus,
				.theiaPostSlider_nav.fontTheme ._button:hover svg,
				.theiaPostSlider_nav.fontTheme ._button:focus svg {
					color: #ffa338;
					fill: #ffa338;
				}
	
				.theiaPostSlider_nav.fontTheme ._disabled,				 
                .theiaPostSlider_nav.fontTheme ._disabled svg {
					color: #777777 !important;
					fill: #777777 !important;
				}
			
</style>
<link rel='stylesheet' id='theiaPostSlider-font-css'  href='https://plugtimes.com/wp-content/plugins/theia-post-slider-premium/assets/fonts/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://plugtimes.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-css-styles-css'  href='https://plugtimes.com/wp-content/themes/jannah/assets/css/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-css-ilightbox-css'  href='https://plugtimes.com/wp-content/themes/jannah/assets/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<style id='tie-css-ilightbox-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/10.7/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' id='jquery-core-js-extra'>
/* <![CDATA[ */
var tie = {"is_rtl":"","ajaxurl":"https:\/\/plugtimes.com\/wp-admin\/admin-ajax.php","mobile_menu_active":"true","mobile_menu_top":"","mobile_menu_parent":"","lightbox_all":"true","lightbox_gallery":"true","lightbox_skin":"dark","lightbox_thumb":"horizontal","lightbox_arrows":"true","is_singular":"1","is_sticky_video":"1","reading_indicator":"true","lazyload":"","select_share":"","select_share_twitter":"true","select_share_facebook":"true","select_share_linkedin":"true","select_share_email":"","facebook_app_id":"","twitter_username":"","responsive_tables":"true","ad_blocker_detector":"true","sticky_behavior":"default","sticky_desktop":"true","sticky_mobile":"true","sticky_mobile_behavior":"default","ajax_loader":"<div class=\"loader-overlay\">\n\t\t\t\t<div class=\"spinner\">\n\t\t\t\t\t<div class=\"bounce1\"><\/div>\n\t\t\t\t\t<div class=\"bounce2\"><\/div>\n\t\t\t\t\t<div class=\"bounce3\"> <\/div>\n\t\t\t\t<\/div>\n\t\t\t<\/div>","type_to_search":"1","lang_no_results":"Nothing Found"};
/* ]]> */
</script>
<script type='text/javascript' defer src='https://c0.wp.com/c/5.9.2/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' defer src='https://c0.wp.com/c/5.9.2/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='cookie-law-info-js-extra'>
/* <![CDATA[ */
var Cli_Data = {"nn_cookie_ids":[],"cookielist":[],"non_necessary_cookies":[],"ccpaEnabled":"","ccpaRegionBased":"","ccpaBarEnabled":"","strictlyEnabled":["necessary","obligatoire"],"ccpaType":"gdpr","js_blocking":"","custom_integration":"","triggerDomRefresh":"","secure_cookies":""};
var cli_cookiebar_settings = {"animate_speed_hide":"500","animate_speed_show":"500","background":"#ffffff","border":"#b1a6a6c2","border_on":"","button_1_button_colour":"#1670bf","button_1_button_hover":"#125a99","button_1_link_colour":"#fff","button_1_as_button":"1","button_1_new_win":"","button_2_button_colour":"#136ebf","button_2_button_hover":"#0f5899","button_2_link_colour":"#ffffff","button_2_as_button":"1","button_2_hidebar":"fffffff","button_3_button_colour":"#000","button_3_button_hover":"#000000","button_3_link_colour":"#fff","button_3_as_button":"1","button_3_new_win":"","button_4_button_colour":"#000","button_4_button_hover":"#000000","button_4_link_colour":"#fff","button_4_as_button":"1","button_7_button_colour":"#61a229","button_7_button_hover":"#4e8221","button_7_link_colour":"#fff","button_7_as_button":"1","button_7_new_win":"","font_family":"Verdana, Geneva","header_fix":"","notify_animate_hide":"1","notify_animate_show":"","notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":"","scroll_close_reload":"","accept_close_reload":"","reject_close_reload":"","showagain_tab":"","showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#136ebf","show_once_yn":"","show_once":"10000","logging_on":"","as_popup":"","popup_overlay":"1","bar_heading_text":"","cookie_bar_as":"banner","popup_showagain_position":"bottom-right","widget_position":"left"};
var log_object = {"ajax_url":"https:\/\/plugtimes.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' defer src='https://plugtimes.com/wp-content/plugins/cookie-law-info/public/js/cookie-law-info-public.js' id='cookie-law-info-js'></script>
<script type='text/javascript' defer src='https://plugtimes.com/wp-content/plugins/theia-post-slider-premium/dist/js/jquery.history.js' id='history.js-js'></script>
<script type='text/javascript' defer src='https://plugtimes.com/wp-content/plugins/theia-post-slider-premium/dist/js/async.min.js' id='async.js-js'></script>
<script type='text/javascript' defer src='https://plugtimes.com/wp-content/plugins/theia-post-slider-premium/dist/js/tps.js' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' defer src='https://plugtimes.com/wp-content/plugins/theia-post-slider-premium/dist/js/main.js' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' defer src='https://plugtimes.com/wp-content/plugins/theia-post-slider-premium/dist/js/tps-transition-slide.js' id='theiaPostSlider/transition.js-js'></script>
<link rel="https://api.w.org/" href="https://plugtimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://plugtimes.com/wp-json/wp/v2/posts/36592" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://plugtimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://plugtimes.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.2" />
<link rel='shortlink' href='https://wp.me/pake9R-9wc' />
<link rel="alternate" type="application/json+oembed" href="https://plugtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fplugtimes.com%2F2022%2F03%2Fmorris-chestnut-star-hollywood-walk-of-fame%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://plugtimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fplugtimes.com%2F2022%2F03%2Fmorris-chestnut-star-hollywood-walk-of-fame%2F&#038;format=xml" />
<meta property="fb:app_id" content="1323769234338022"/><script type="text/javascript">
!function(t,e,s){"use strict";function a(t){t=t||{};var e="https://track.atom-data.io/",s="1.0.1";this.options={endpoint:!!t.endpoint&&t.endpoint.toString()||e,apiVersion:s,auth:t.auth?t.auth:""}}function n(t,e){this.endpoint=t.toString()||"",this.params=e||{},this.headers={contentType:"application/json;charset=UTF-8"},this.xhr=XMLHttpRequest?new XMLHttpRequest:new ActiveXObject("Microsoft.XMLHTTP")}function r(t,e,s){this.error=t,this.response=e,this.status=s}t.IronSourceAtom=a,a.prototype.putEvent=function(t,e){if(t=t||{},!t.table)return e("Stream is required",null);if(!t.data)return e("Data is required",null);t.apiVersion=this.options.apiVersion,t.auth=this.options.auth;var s=new n(this.options.endpoint,t);return t.method&&"GET"===t.method.toUpperCase()?s.get(e):s.post(e)},a.prototype.putEvents=function(t,e){if(t=t||{},!t.table)return e("Stream is required",null);if(!(t.data&&t.data instanceof Array&&t.data.length))return e("Data (must be not empty array) is required",null);t.apiVersion=this.options.apiVersion,t.auth=this.options.auth;var s=new n(this.options.endpoint+"/bulk",t);return t.method&&"GET"===t.method.toUpperCase()?s.get(e):s.post(e)},a.prototype.health=function(t){var e=new n(this.options.endpoint,{table:"health_check",data:"null"});return e.get(t)},"undefined"!=typeof module&&module.exports&&(module.exports={IronSourceAtom:a,Request:n,Response:r}),n.prototype.post=function(t){if(!this.params.table||!this.params.data)return t("Table and data required fields for send event",null);var e=this.xhr,s=JSON.stringify({data:this.params.data,table:this.params.table,apiVersion:this.params.apiVersion,auth:this.params.auth});e.open("POST",this.endpoint,!0),e.setRequestHeader("Content-type",this.headers.contentType),e.setRequestHeader("x-ironsource-atom-sdk-type","js"),e.setRequestHeader("x-ironsource-atom-sdk-version","1.0.1"),e.onreadystatechange=function(){if(e.readyState===XMLHttpRequest.DONE){var s;e.status>=200&&e.status<400?(s=new r(!1,e.response,e.status),!!t&&t(null,s.data())):(s=new r(!0,e.response,e.status),!!t&&t(s.err(),null))}},e.send(s)},n.prototype.get=function(t){if(!this.params.table||!this.params.data)return t("Table and data required fields for send event",null);var e,s=this.xhr,a=JSON.stringify({table:this.params.table,data:this.params.data,apiVersion:this.params.apiVersion,auth:this.params.auth});try{e=btoa(a)}catch(n){}s.open("GET",this.endpoint+"?data="+e,!0),s.setRequestHeader("Content-type",this.headers.contentType),s.setRequestHeader("x-ironsource-atom-sdk-type","js"),s.setRequestHeader("x-ironsource-atom-sdk-version","1.0.1"),s.onreadystatechange=function(){if(s.readyState===XMLHttpRequest.DONE){var e;s.status>=200&&s.status<400?(e=new r(!1,s.response,s.status),!!t&&t(null,e.data())):(e=new r(!0,s.response,s.status),!!t&&t(e.err(),null))}},s.send()},r.prototype.data=function(){return this.error?null:JSON.parse(this.response)},r.prototype.err=function(){return{message:this.response,status:this.status}}}(window,document);

var options = {
  endpoint: 'https://track.atom-data.io/',
}

var atom = new IronSourceAtom(options);

var params = {
  table: 'wp_comments_plugin', //your target stream name
  data: JSON.stringify({
    'domain': window.location.hostname,
    'url': window.location.protocol + "//" + window.location.host + "/" + window.location.pathname,
    'lang': window.navigator.userLanguage || window.navigator.language,
    'referrer': document.referrer || '',
    'pn': 'fcp'
  }), //String with any data and any structure.
  method: 'POST' // optional, default "POST"
}

var callback = function() {};

if ( Math.floor( Math.random() * 100 ) + 1 === 1 ) {
  atom.putEvent(params, callback);
}
</script><style type='text/css'>img#wpstats{display:none}</style>
	
<meta name="generator" content="Jannah | Shared by VestaThemes.com 3.2.0" />
<meta name="theme-color" content="#fe4641" /><meta name="viewport" content="width=device-width, initial-scale=1.0" />			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
					<script>
						WebFontConfig ={
							google:{
								families: ['Poppins:regular,500,600,700:latin']
							}
						};
						(function(){
							var wf   = document.createElement('script');
							wf.src   = '//ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
							wf.type  = 'text/javascript';
							wf.async = 'true';
							var s = document.getElementsByTagName('script')[0];
							s.parentNode.insertBefore(wf, s);
						})();
					</script>
				<link rel="icon" href="https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/07/cropped-PlugTimes-emoticon-2.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/07/cropped-PlugTimes-emoticon-2.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/07/cropped-PlugTimes-emoticon-2.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/07/cropped-PlugTimes-emoticon-2.png?fit=270%2C270&#038;ssl=1" />
<meta name="google-site-verification" content="CE8q_B0Ps_f9X9bhlN7Yq5tZrss5EmpViWo_3Q5A4Cc" />
<meta name="yandex-verification" content="77bf9b3095ccdc52" />
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-127169182-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-127169182-1');
</script>
	<meta name="p:domain_verify" content="b6f76ed2d3fb24abb09b1b0c03a460cd"/>
<script type="text/javascript" data-cfasync="false"> 
 var _foxpush = _foxpush || []; 
 _foxpush.push(['_setDomain', 'plugtimescom']); 
 (function(){ 
 var foxscript = document.createElement('script'); 
 foxscript.src = '//cdn.foxpush.net/sdk/foxpush_SDK_min.js'; 
 foxscript.type = 'text/javascript'; 
 foxscript.async = 'true'; 
 var fox_s = document.getElementsByTagName('script')[0]; 
 fox_s.parentNode.insertBefore(foxscript, fox_s);})(); 
 </script>
	<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N7MSP8P');</script>
<!-- End Google Tag Manager -->
	<script type="text/javascript" data-cfasync="false"> 
 var _foxpush = _foxpush || []; 
 _foxpush.push(['_setDomain', 'plugtimescom']); 
 (function(){ 
 var foxscript = document.createElement('script'); 
 foxscript.src = '//cdn.foxpush.net/sdk/foxpush_SDK_min.js'; 
 foxscript.type = 'text/javascript'; 
 foxscript.async = 'true'; 
 var fox_s = document.getElementsByTagName('script')[0]; 
 fox_s.parentNode.insertBefore(foxscript, fox_s);})(); 
 </script>
</head>
<body id="tie-body" class="post-template-default single single-post postid-36592 single-format-standard theiaPostSlider_body boxed-layout wrapper-has-shadow block-head-1 magazine1 is-thumb-overlay-disabled is-desktop is-header-layout-3 has-header-ad sidebar-right has-sidebar post-layout-1 narrow-title-narrow-media is-standard-format hide_share_post_top hide_share_post_bottom">
	<script type='text/javascript' src='//pl17081841.effectivecpmcontent.com/8e/a1/0e/8ea10ebbd6aa899a1b08baadab62bd3b.js'></script>
	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N7MSP8P"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-3691912725599556"
     crossorigin="anonymous"></script>

<div class="background-overlay">

	<div id="tie-container" class="site tie-container">

		
		<div id="tie-wrapper">

			
<header id="theme-header" class="theme-header header-layout-3 main-nav-light main-nav-below main-nav-boxed top-nav-active top-nav-light top-nav-above has-shadow mobile-header-default">
	
<nav id="top-nav" class="has-date-menu top-nav header-nav" aria-label="Secondary Navigation">
	<div class="container">
		<div class="topbar-wrapper">

			
					<div class="topbar-today-date">
						<span class="fa fa-clock-o" aria-hidden="true"></span>
						<strong class="inner-text">Sunday, March 27 2022</strong>
					</div>
					
			<div class="tie-alignleft">
				<div class="top-menu header-menu"><ul id="menu-top-most-menu" class="menu"><li id="menu-item-13194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13194"><a href="https://plugtimes.com/about-us/">About Us</a></li>
<li id="menu-item-13199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13199"><a href="https://plugtimes.com/contact-us/">Contact Us</a></li>
<li id="menu-item-13197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13197"><a href="https://plugtimes.com/term-conditions/">Terms &#038; Conditions</a></li>
</ul></div>			</div><!-- .tie-alignleft /-->

			<div class="tie-alignright">
							</div><!-- .tie-alignright /-->

		</div><!-- .topbar-wrapper /-->
	</div><!-- .container /-->
</nav><!-- #top-nav /-->

<div class="container">
	<div class="tie-row logo-row">

		
		<div class="logo-wrapper">
			<div class="tie-col-md-4 logo-container">
				
		<a href="#" id="mobile-menu-icon">
			<span class="nav-icon"></span>

				<span class="screen-reader-text">Menu</span>		</a>
		
		<div id="logo" class="image-logo" style="margin-top: 20px; margin-bottom: 20px;">

			
			<a title="PlugTimes.com" href="https://plugtimes.com/">
				
					<img src="https://plugtimes.com/wp-content/uploads/2021/03/PlugTimes-logo.png" alt="PlugTimes.com" class="logo_normal" width="2383" height="500" style="max-height:500px; width: auto;">
					<img src="https://plugtimes.com/wp-content/uploads/2021/03/PlugTimes-logo.png" alt="PlugTimes.com" class="logo_2x" width="2383" height="500" style="max-height:500px; width: auto;">
							</a>

			
		</div><!-- #logo /-->

					</div><!-- .tie-col /-->
		</div><!-- .logo-wrapper /-->

		<div class="tie-col-md-8 stream-item stream-item-top-wrapper"><div class="stream-item-top"><script type="text/javascript">
	atOptions = {
		'key' : '2c7fb36298a66f7f405f3ca6fe8ac1e1',
		'format' : 'iframe',
		'height' : 90,
		'width' : 728,
		'params' : {}
	};
	document.write('<scr' + 'ipt type="text/javascript" src="http' + (location.protocol === 'https:' ? 's' : '') + '://www.highconvertingformats.com/2c7fb36298a66f7f405f3ca6fe8ac1e1/invoke.js"></scr' + 'ipt>');
</script>
</div></div><!-- .tie-col /-->
	</div><!-- .tie-row /-->
</div><!-- .container /-->

<div class="main-nav-wrapper">
	<nav id="main-nav"  class="main-nav header-nav"  aria-label="Primary Navigation">
		<div class="container">

			<div class="main-menu-wrapper">

				
				<div id="menu-components-wrap">

					
		<div id="sticky-logo" class="image-logo">

			
			<a title="PlugTimes.com" href="https://plugtimes.com/">
				
					<img src="https://plugtimes.com/wp-content/uploads/2021/03/PlugTimes-logo.png" alt="PlugTimes.com" class="logo_normal" >
					<img src="https://plugtimes.com/wp-content/uploads/2021/03/PlugTimes-logo.png" alt="PlugTimes.com" class="logo_2x" >
							</a>

			
		</div><!-- #Sticky-logo /-->

		<div class="flex-placeholder"></div>

		
					<div class="main-menu main-menu-wrap tie-alignleft">
						<div id="main-nav-menu" class="main-menu header-menu"><ul id="menu-main-menu" class="menu" role="menubar"><li id="menu-item-26" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-26"><a href="https://plugtimes.com">HOME</a></li>
<li id="menu-item-6904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6904"><a href="https://plugtimes.com/news/">NEWS</a></li>
<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22 tie-current-menu"><a href="https://plugtimes.com/entertainment/">ENTERTAINMENT</a></li>
<li id="menu-item-16683" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16683"><a href="https://plugtimes.com/business/">BUSINESS</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://plugtimes.com/sports/">SPORTS</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="https://plugtimes.com/technology/">TECHNOLOGY</a></li>
<li id="menu-item-5586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5586"><a href="https://plugtimes.com/editorials/">EDITORIALS</a></li>
</ul></div>					</div><!-- .main-menu.tie-alignleft /-->

					<ul class="components">		<li class="search-bar menu-item custom-menu-link" aria-label="Search">
			<form method="get" id="search" action="https://plugtimes.com//">
				<input id="search-input" type="text" name="s" title="Search for" placeholder="Search for" />
				<button id="search-submit" type="submit"><span class="fa fa-search" aria-hidden="true"></span></button>
			</form>
		</li>
		</ul><!-- Components -->
				</div><!-- #menu-components-wrap /-->
			</div><!-- .main-menu-wrapper /-->
		</div><!-- .container /-->
	</nav><!-- #main-nav /-->
</div><!-- .main-nav-wrapper /-->

</header>


			<div id="content" class="site-content container">
				<div class="tie-row main-content-row">
		

<div class="main-content tie-col-md-8 tie-col-xs-12" role="main">

	
	<article id="the-post" class="container-wrapper post-content tie-standard">

		
<header class="entry-header-outer">

	<nav id="breadcrumb"><a href="https://plugtimes.com/"><span class="fa fa-home" aria-hidden="true"></span> Home</a><em class="delimiter">/</em><a href="https://plugtimes.com/entertainment/">Entertainment</a><em class="delimiter">/</em><span class="current">Morris Chestnut Receives Star on Hollywood Walk of Fame</span></nav><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","@id":"#Breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"name":"Home","@id":"https:\/\/plugtimes.com\/"}},{"@type":"ListItem","position":2,"item":{"name":"Entertainment","@id":"https:\/\/plugtimes.com\/entertainment\/"}}]}</script>
	<div class="entry-header">

		
		<h1 class="post-title entry-title">Morris Chestnut Receives Star on Hollywood Walk of Fame</h1>

		<div class="post-meta">
					<span class="meta-author-avatar">
						<a href="https://plugtimes.com/author/plugtimesonline/"><img alt src="https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=140&#038;d=mm&#038;r=g" class="avatar avatar-140 photo jetpack-lazy-image" height="140" width="140" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=280&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=140&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=140&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=280&#038;d=mm&#038;r=g 2x' class='avatar avatar-140 photo' height='140' width='140' loading='lazy'/></noscript>
						</a>
					</span>
				
				<span class="meta-author meta-item"><a href="https://plugtimes.com/author/plugtimesonline/" class="author-name" title="PlugTimes.com">PlugTimes.com</a>
				</span>
			
					<a href="http://PlugTimesHQ" class="author-twitter-link" target="_blank" rel="nofollow noopener">
						<span class="fa fa-twitter" aria-hidden="true"></span>
						<span class="screen-reader-text"></span>
					</a>
				
					<a href="mailto:plugtimesonline@gmail.com" class="author-email-link" target="_blank" rel="nofollow noopener">
						<span class="fa fa-envelope" aria-hidden="true"></span>
						<span class="screen-reader-text"></span>
					</a>
				<span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>March 26, 2022</span></span><div class="clearfix"></div></div><!-- .post-meta -->	</div><!-- .entry-header /-->

	
	
</header><!-- .entry-header-outer /-->

<div  class="featured-area"><div class="featured-area-inner"><figure class="single-featured-image"><img width="780" height="405" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star.jpg?resize=780%2C405&amp;ssl=1" class="attachment-jannah-image-post size-jannah-image-post wp-post-image jetpack-lazy-image" alt="Morris Chestnut hollywood walk of fame star" data-lazy-src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star.jpg?resize=780%2C405&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></figure></div></div>
		<div class="entry-content entry clearfix">

			
			<div class="at-above-post addthis_tool" data-url="https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/"></div><div id="tps_slideContainer_36592" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">

<h2>Morris Chestnut earns a Hollywood Walk of Fame star following years of remarkable performance in film.</h2>
<p>The star presentation to the Hollywood actor is dated Wednesday, March 23, 2022.</p>
<p><strong>Morris Chestnut</strong>&#8216;s star on the <strong>Hollywood Walk of Fame</strong> comes the same day he is celebrating his mother&#8217;s birthday.</p><div class="stream-item stream-item-in-post stream-item-inline-post aligncenter"><script type="text/javascript">
	atOptions = {
		'key' : '2c7fb36298a66f7f405f3ca6fe8ac1e1',
		'format' : 'iframe',
		'height' : 90,
		'width' : 728,
		'params' : {}
	};
	document.write('<scr' + 'ipt type="text/javascript" src="http' + (location.protocol === 'https:' ? 's' : '') + '://www.highconvertingformats.com/2c7fb36298a66f7f405f3ca6fe8ac1e1/invoke.js"></scr' + 'ipt>');
</script></div>
<p>The delighted actor reacts to this honour of his induction while acknowledging that it is <em>&#8220;a dream come true.&#8221;</em></p>
<p><em>&#8220;What a day! A dream come true. It’s even more special to be celebrating it on mom’s birthday. Thank you,</em>&#8221; the &#8216;Like Me&#8217; actor shares.</p><div class="stream-item stream-item-in-post stream-item-inline-post aligncenter"><script async="async" data-cfasync="false" src="//pl17081798.effectivecpmcontent.com/c91503a1b4c54bee75e605f8e92ae444/invoke.js"></script>
<div id="container-c91503a1b4c54bee75e605f8e92ae444"></div></div>
<p>There is already a lot of congratulatory messages going in the direction of <strong>Morris.</strong></p>
<p>While some fans opine that it is long overdue, other are also on the view that it is better late than never.</p>
<p><strong>Morris Chestnut</strong> is noted for his outstanding role in movies like <em>&#8216;The Best Man&#8217;, &#8216;Two Can Play That Game&#8217;</em> and<em> &#8216;Boyz n The Hood&#8217;.</em></p>
<p><img loading="lazy" class="aligncenter wp-image-36594 jetpack-lazy-image" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star-1.jpg?resize=481%2C600&#038;ssl=1" alt="Morris Chestnut hollywood walk of fame star" width="481" height="600" data-recalc-dims="1" data-lazy-srcset="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star-1.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star-1.jpg?resize=241%2C300&amp;ssl=1 241w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star-1.jpg?resize=768%2C957&amp;ssl=1 768w" data-lazy-sizes="(max-width: 481px) 100vw, 481px" data-lazy-src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star-1.jpg?resize=481%2C600&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" class="aligncenter wp-image-36594" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star-1.jpg?resize=481%2C600&#038;ssl=1" alt="Morris Chestnut hollywood walk of fame star" width="481" height="600" srcset="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star-1.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star-1.jpg?resize=241%2C300&amp;ssl=1 241w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Morris-Chestnut-hollywood-walk-of-fame-star-1.jpg?resize=768%2C957&amp;ssl=1 768w" sizes="(max-width: 481px) 100vw, 481px" data-recalc-dims="1" /></noscript></p>
<p><strong>Source: PlugTimes.com</strong></p>

</div></div><div class="theiaPostSlider_footer _footer"></div><p><!-- END THEIA POST SLIDER --></p>
<!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/"></div><!-- AddThis Share Buttons generic via filter on the_content --><!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><div class="fb-comments" data-href="https://plugtimes.com/2022/03/morris-chestnut-star-hollywood-walk-of-fame/" data-num-posts="10" data-width="100%" data-colorscheme="light"></div><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_36592&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your &amp;leftarrow; &amp;rightarrow; (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;font&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/plugtimes.com\/2022\/03\/morris-chestnut-star-hollywood-walk-of-fame\/&quot;,&quot;postId&quot;:36592,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/plugtimes.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;],&quot;prevFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-left\&quot;&gt;&lt;\/span&gt;&quot;,&quot;nextFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-right\&quot;&gt;&lt;\/span&gt;&quot;}' 
					 data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div>
			<div class="stream-item stream-item-below-post-content"><script type="text/javascript">
	atOptions = {
		'key' : '2c7fb36298a66f7f405f3ca6fe8ac1e1',
		'format' : 'iframe',
		'height' : 90,
		'width' : 728,
		'params' : {}
	};
	document.write('<scr' + 'ipt type="text/javascript" src="http' + (location.protocol === 'https:' ? 's' : '') + '://www.highconvertingformats.com/2c7fb36298a66f7f405f3ca6fe8ac1e1/invoke.js"></scr' + 'ipt>');
</script></div>
		</div><!-- .entry-content /-->

		<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","dateCreated":"2022-03-26T21:48:18+00:00","datePublished":"2022-03-26T21:48:18+00:00","dateModified":"2022-03-26T21:48:20+00:00","headline":"Morris Chestnut Receives Star on Hollywood Walk of Fame","name":"Morris Chestnut Receives Star on Hollywood Walk of Fame","keywords":"Hollywood Walk of Fame,Morris Chestnut","url":"https:\/\/plugtimes.com\/2022\/03\/morris-chestnut-star-hollywood-walk-of-fame\/","description":"Morris Chestnut earns a Hollywood Walk of Fame star following years of remarkable performance in film. The star presentation to the Hollywood actor is dated Wednesday, March 23, 2022. Morris Chestnut'","copyrightYear":"2022","articleSection":"Entertainment","articleBody":"Morris Chestnut earns a Hollywood Walk of Fame star following years of remarkable performance in film.\nThe star presentation to the Hollywood actor is dated Wednesday, March 23, 2022.\n\nMorris Chestnut's star on the Hollywood Walk of Fame comes the same day he is celebrating his mother's birthday.\n\nThe delighted actor reacts to this honour of his induction while acknowledging that it is \"a dream come true.\"\n\n\"What a day! A dream come true. It\u2019s even more special to be celebrating it on mom\u2019s birthday. Thank you,\" the 'Like Me' actor shares.\n\nThere is already a lot of congratulatory messages going in the direction of Morris.\n\nWhile some fans opine that it is long overdue, other are also on the view that it is better late than never.\n\nMorris Chestnut is noted for his outstanding role in movies like 'The Best Man', 'Two Can Play That Game' and 'Boyz n The Hood'.\n\n\n\nSource: PlugTimes.com","publisher":{"@id":"#Publisher","@type":"Organization","name":"PlugTimes.com","logo":{"@type":"ImageObject","url":"https:\/\/plugtimes.com\/wp-content\/uploads\/2021\/03\/PlugTimes-logo.png"},"sameAs":["https:\/\/plugtimes.com\/feed\/","https:\/\/facebook.com\/PlugTimesHQ","https:\/\/twitter.com\/PlugTimesHQ","https:\/\/www.youtube.com\/channel\/UCfzisG003ehwbPeat8eEROA","https:\/\/instagram.com\/PlugTimesHQ"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/plugtimes.com\/2022\/03\/morris-chestnut-star-hollywood-walk-of-fame\/","breadcrumb":{"@id":"#Breadcrumb"}},"author":{"@type":"Person","name":"PlugTimes.com","url":"https:\/\/plugtimes.com\/author\/plugtimesonline\/"},"image":{"@type":"ImageObject","url":"https:\/\/i0.wp.com\/plugtimes.com\/wp-content\/uploads\/2022\/03\/Morris-Chestnut-hollywood-walk-of-fame-star.jpg?fit=800%2C474&ssl=1","width":800,"height":474}}</script>
	</article><!-- #the-post /-->

	
	<div class="post-components">

		
		<div class="about-author container-wrapper">

								<div class="author-avatar">
						<a href="https://plugtimes.com/author/plugtimesonline/">
							<img alt src="https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=180&#038;d=mm&#038;r=g" class="avatar avatar-180 photo jetpack-lazy-image" height="180" width="180" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=360&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=180&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=180&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/b63c8fc6c80d1214634fee0a006b52fc?s=360&#038;d=mm&#038;r=g 2x' class='avatar avatar-180 photo' height='180' width='180' loading='lazy'/></noscript>						</a>
					</div><!-- .author-avatar /-->
					
			<div class="author-info">
				<h3 class="author-name"><a href="https://plugtimes.com/author/plugtimesonline/">PlugTimes.com</a></h3>

				<div class="author-bio">
					Latest Ghana News, Entertainment, Business, Sports, Technology | Celebrity Gossip, Music, Movies, Dance, Fashion, Events and more from Ghana, Africa, and the World				</div><!-- .author-bio /-->

				<ul class="social-icons">
								<li class="social-icons-item">
									<a href="https://plugtimes.com" rel="external noopener" target="_blank" class="social-link url-social-icon">
									<span class="fa fa-home" aria-hidden="true"></span>
									<span class="screen-reader-text">Website</span>
									</a>
								</li>
							
								<li class="social-icons-item">
									<a href="https://facebook.com/PlugTimesHQ" rel="external noopener" target="_blank" class="social-link facebook-social-icon">
									<span class="fa fa-facebook" aria-hidden="true"></span>
									<span class="screen-reader-text">Facebook</span>
									</a>
								</li>
							
								<li class="social-icons-item">
									<a href="http://PlugTimesHQ" rel="external noopener" target="_blank" class="social-link twitter-social-icon">
									<span class="fa fa-twitter" aria-hidden="true"></span>
									<span class="screen-reader-text">Twitter</span>
									</a>
								</li>
							
								<li class="social-icons-item">
									<a href="https://instagram.com/PlugTimesHQ" rel="external noopener" target="_blank" class="social-link instagram-social-icon">
									<span class="fa fa-instagram" aria-hidden="true"></span>
									<span class="screen-reader-text">Instagram</span>
									</a>
								</li>
							</ul>			</div><!-- .author-info /-->
			<div class="clearfix"></div>
		</div><!-- .about-author /-->
		
	

				<div id="related-posts" class="container-wrapper has-extra-post">

					<div class="mag-box-title the-global-title">
						<h3>Related Articles</h3>
					</div>

					<div class="related-posts-list">

					
							<div class="related-item tie-standard">

								
			<a href="https://plugtimes.com/2022/03/3-music-awards-2022-winners/" title="3 Music Awards 2022 Winners | See Full List" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="390" height="220" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/3-music-awards-2022-winners.jpg?resize=390%2C220&amp;ssl=1" class="attachment-jannah-image-large size-jannah-image-large wp-post-image jetpack-lazy-image" alt="3 music awards 2022 winners" loading="lazy" data-lazy-srcset="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/3-music-awards-2022-winners.jpg?resize=390%2C220&amp;ssl=1 390w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/3-music-awards-2022-winners.jpg?zoom=2&amp;resize=390%2C220&amp;ssl=1 780w" data-lazy-sizes="(max-width: 390px) 100vw, 390px" data-lazy-src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/3-music-awards-2022-winners.jpg?resize=390%2C220&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
								<h3 class="post-title"><a href="https://plugtimes.com/2022/03/3-music-awards-2022-winners/" title="3 Music Awards 2022 Winners | See Full List">3 Music Awards 2022 Winners | See Full List</a></h3>

								<div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>March 27, 2022</span></span><div class="clearfix"></div></div><!-- .post-meta -->							</div><!-- .related-item /-->

						
							<div class="related-item tie-standard">

								
			<a href="https://plugtimes.com/2022/03/watch-live-3-music-awards-2022-ceremony/" title="WATCH LIVE: 3 Music Awards 2022 Ceremony" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="390" height="220" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/3-music-awards-2022.jpg?resize=390%2C220&amp;ssl=1" class="attachment-jannah-image-large size-jannah-image-large wp-post-image jetpack-lazy-image" alt="3 music awards 2022" loading="lazy" data-lazy-src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/3-music-awards-2022.jpg?resize=390%2C220&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
								<h3 class="post-title"><a href="https://plugtimes.com/2022/03/watch-live-3-music-awards-2022-ceremony/" title="WATCH LIVE: 3 Music Awards 2022 Ceremony">WATCH LIVE: 3 Music Awards 2022 Ceremony</a></h3>

								<div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>March 26, 2022</span></span><div class="clearfix"></div></div><!-- .post-meta -->							</div><!-- .related-item /-->

						
							<div class="related-item tie-standard">

								
			<a href="https://plugtimes.com/2022/03/oscars-2022-winners/" title="Oscars 2022 Winners | See Full List" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="390" height="220" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/01/Oscars.jpg?resize=390%2C220&amp;ssl=1" class="attachment-jannah-image-large size-jannah-image-large wp-post-image jetpack-lazy-image" alt="Oscars 2022 winners" loading="lazy" data-lazy-srcset="https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/01/Oscars.jpg?w=1920&amp;ssl=1 1920w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/01/Oscars.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/01/Oscars.jpg?resize=768%2C432&amp;ssl=1 768w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/01/Oscars.jpg?resize=1024%2C576&amp;ssl=1 1024w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/01/Oscars.jpg?w=1200&amp;ssl=1 1200w" data-lazy-sizes="(max-width: 390px) 100vw, 390px" data-lazy-src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2019/01/Oscars.jpg?resize=390%2C220&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
								<h3 class="post-title"><a href="https://plugtimes.com/2022/03/oscars-2022-winners/" title="Oscars 2022 Winners | See Full List">Oscars 2022 Winners | See Full List</a></h3>

								<div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>March 26, 2022</span></span><div class="clearfix"></div></div><!-- .post-meta -->							</div><!-- .related-item /-->

						
							<div class="related-item tie-standard">

								
			<a href="https://plugtimes.com/2022/03/shocking-dr-cann-dead/" title="SHOCKING! Dr Cann is Dead" class="post-thumb">
				<div class="post-thumb-overlay-wrap">
					<div class="post-thumb-overlay">
						<span class="icon"></span>
					</div>
				</div>
			<img width="390" height="220" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/dr-cann.jpg?resize=390%2C220&amp;ssl=1" class="attachment-jannah-image-large size-jannah-image-large wp-post-image jetpack-lazy-image" alt="dr cann death dead die lose" loading="lazy" data-lazy-srcset="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/dr-cann.jpg?resize=390%2C220&amp;ssl=1 390w, https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/dr-cann.jpg?resize=720%2C405&amp;ssl=1 720w" data-lazy-sizes="(max-width: 390px) 100vw, 390px" data-lazy-src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/dr-cann.jpg?resize=390%2C220&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
								<h3 class="post-title"><a href="https://plugtimes.com/2022/03/shocking-dr-cann-dead/" title="SHOCKING! Dr Cann is Dead">SHOCKING! Dr Cann is Dead</a></h3>

								<div class="post-meta"><span class="date meta-item"><span class="fa fa-clock-o" aria-hidden="true"></span> <span>March 25, 2022</span></span><div class="clearfix"></div></div><!-- .post-meta -->							</div><!-- .related-item /-->

						
					</div><!-- .related-posts-list /-->
				</div><!-- #related-posts /-->

			
	</div><!-- .post-components /-->

	
</div><!-- .main-content -->


	<aside class="sidebar tie-col-md-4 tie-col-xs-12 normal-side is-sticky" aria-label="Primary Sidebar">
		<div class="theiaStickySidebar">
			<div id="stream-item-widget-1" class="widget stream-item-widget widget-content-only"><div class="stream-item-widget-content"><span class="stream-title">Advertisement</span><script type="text/javascript">
	atOptions = {
		'key' : 'b18792b0e2d60a5eb055d059295234cc',
		'format' : 'iframe',
		'height' : 250,
		'width' : 300,
		'params' : {}
	};
	document.write('<scr' + 'ipt type="text/javascript" src="http' + (location.protocol === 'https:' ? 's' : '') + '://www.highconvertingformats.com/b18792b0e2d60a5eb055d059295234cc/invoke.js"></scr' + 'ipt>');
</script></div></div><div id="social-statistics-1" class="container-wrapper widget social-statistics-widget"><div class="widget-title the-global-title"><h4>Follow Us @PlugTimesHQ<span class="widget-title-icon fa"></span></h4></div>
			<ul class="solid-social-icons fullwidth-stats-icons Arqam-Lite">
				
							<li class="social-icons-item">
								<a class="rss-social-icon" href="https://plugtimes.com/feed" rel="nofollow noopener" target="_blank">
									<span class="counter-icon fa fa-feed"></span>									<span class="followers">
										<span class="followers-num">0</span>
										<span class="followers-name">Subscribers</span>
									</span>
								</a>
							</li>
							
							<li class="social-icons-item">
								<a class="facebook-social-icon" href="https://www.facebook.com/plugtimeshq" rel="nofollow noopener" target="_blank">
									<span class="counter-icon fa fa-facebook"></span>									<span class="followers">
										<span class="followers-num">19,707</span>
										<span class="followers-name">Likes/Followers</span>
									</span>
								</a>
							</li>
							
							<li class="social-icons-item">
								<a class="twitter-social-icon" href="https://twitter.com/PlugTimesHQ" rel="nofollow noopener" target="_blank">
									<span class="counter-icon fa fa-twitter"></span>									<span class="followers">
										<span class="followers-num">0</span>
										<span class="followers-name">Followers</span>
									</span>
								</a>
							</li>
							
							<li class="social-icons-item">
								<a class="youtube-social-icon" href="https://youtube.com/channel/UCfzisG003ehwbPeat8eEROA" rel="nofollow noopener" target="_blank">
									<span class="counter-icon fa fa-youtube"></span>									<span class="followers">
										<span class="followers-num">0</span>
										<span class="followers-name">Subscribers</span>
									</span>
								</a>
							</li>
							
							<li class="social-icons-item">
								<a class="instagram-social-icon" href="https://instagram.com/PlugTimesHQ" rel="nofollow noopener" target="_blank">
									<span class="counter-icon fa fa-instagram"></span>									<span class="followers">
										<span class="followers-num">0</span>
										<span class="followers-name">Followers</span>
									</span>
								</a>
							</li>
										</ul>
			<div class="clearfix"></div></div><!-- .widget /--><div id="stream-item-widget-7" class="container-wrapper widget stream-item-widget"><div class="stream-item-widget-content"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-3691912725599556"
     crossorigin="anonymous"></script>
<!-- fixed 300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-3691912725599556"
     data-ad-slot="1217307770"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div class="clearfix"></div></div><!-- .widget /--><div id="block-4" class="container-wrapper widget widget_block">
<figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="1220" height="687" src="https://www.youtube.com/embed/WZIe2NQkedo?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span>
</div></figure>
<div class="clearfix"></div></div><!-- .widget /-->		</div><!-- .theiaStickySidebar /-->
	</aside><!-- .sidebar /-->
	
				</div><!-- .main-content-row /-->
			</div><!-- #content /-->
		
<footer id="footer" class="site-footer dark-skin dark-widgetized-area">

	
			<div id="footer-widgets-container">
				<div class="container">
					

		<div class="footer-widget-area ">
			<div class="tie-row">

									<div class="tie-col-sm-4 normal-side">
						<div id="pages-3" class="container-wrapper widget widget_pages"><div class="widget-title the-global-title"><h4>Key Info<span class="widget-title-icon fa"></span></h4></div>
			<ul>
				<li class="page_item page-item-5"><a href="https://plugtimes.com/about-us/">ABOUT US</a></li>
<li class="page_item page-item-3"><a href="https://plugtimes.com/privacy-policy/">PRIVACY POLICY</a></li>
<li class="page_item page-item-12476"><a href="https://plugtimes.com/cookies-policy/">COOKIES POLICY</a></li>
<li class="page_item page-item-17"><a href="https://plugtimes.com/term-conditions/">TERM &#038; CONDITIONS</a></li>
<li class="page_item page-item-6437"><a href="https://plugtimes.com/disclaimer/">DISCLAIMER</a></li>
<li class="page_item page-item-7"><a href="https://plugtimes.com/contact-us/">CONTACT US</a></li>
<li class="page_item page-item-14"><a href="https://plugtimes.com/sitemap/">SITEMAP</a></li>
			</ul>

			<div class="clearfix"></div></div><!-- .widget /-->					</div><!-- .tie-col /-->
				
									<div class="tie-col-sm-4 normal-side">
						<div id="block-3" class="container-wrapper widget widget_block">
<div class="wp-block-columns">
<div class="wp-block-column" style="flex-basis:100%">
<div class="wp-block-columns">
<div class="wp-block-column" style="flex-basis:100%">
<div class="wp-container-623ff1a13e754 wp-block-group"><div class="wp-block-group__inner-container"><ul class="wp-block-categories-list wp-block-categories">	<li class="cat-item cat-item-8241"><a href="https://plugtimes.com/business/" title="Ghana Business News – Latest on Insurance, Economy, Banking, Finance, Money, Trade, Forex, Cryptocurrency, and more | Africa, Americas, EU, Asia, Oceania

">Business</a>
</li>
	<li class="cat-item cat-item-702"><a href="https://plugtimes.com/editorials/" title="Latest Opinion, Feature, and Analysis from PlugTimes.com Newsroom, our cherished readers, and Guest Bloggers from Ghana, Africa, Americas, Europe, Asia etc.">Editorials</a>
</li>
	<li class="cat-item cat-item-3"><a href="https://plugtimes.com/entertainment/" title="Ghana Entertainment News - Latest Showbiz, Celebrities, Music, Movies, Dance, Fashion, Lifestyle, Events, Tourism, Travel, Food, etc. | Africa, Americas, EU">Entertainment</a>
</li>
	<li class="cat-item cat-item-8629"><a href="https://plugtimes.com/music-plug/" title="Latest Music Download -- Ghana, Nigeria, South Africa, Kenya, Ivory Coast, Togo, Jamaica, African Songs, Lyrics, Music Videos, Mixtapes | Gospel, Highlife, Hiplife, Hip-hop, Afrobeat, Kwaito, Coupé-Décalé, Bongo Flava, Reggae, Dancehall, Soca, and many more! ">Music Plug!</a>
</li>
	<li class="cat-item cat-item-4978"><a href="https://plugtimes.com/news/" title="Ghana News, Africa News, World News, Current Affairs, Social, Diplomacy, and many more">News</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://plugtimes.com/sports/" title="Ghana Sports News - Football, Boxing, Basketball, Tennis, Cricket, Rugby, Athletics, Golf, Racing, Swimming, Netball | Transfers, Matches, Results and more">Sports</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://plugtimes.com/technology/" title="Ghana Technology News - Latest on Fintech, Computing, Games, Gadgets, Websites, Apps, Discoveries, Internet, Product Reviews, and more!">Technology</a>
</li>
</ul></div></div>
</div>
</div>
</div>
</div>
<div class="clearfix"></div></div><!-- .widget /-->					</div><!-- .tie-col /-->
				
									<div class="tie-col-sm-4 normal-side">
						<div id="tie-newsletter-1" class="container-wrapper widget subscribe-widget">
			<div class="widget-inner-wrap">

										<div id="mc_embed_signup-tie-newsletter-1">
							<form action="#" method="post" id="mc-embedded-subscribe-form-tie-newsletter-1" name="mc-embedded-subscribe-form" class="subscribe-form validate" target="_blank" novalidate>
									<div class="mc-field-group">
										<label class="screen-reader-text" for="mce-EMAIL-tie-newsletter-1">Enter your Email address</label>
										<input type="email" value="" id="mce-EMAIL-tie-newsletter-1" placeholder="Enter your Email address" name="EMAIL" class="subscribe-input required email">
									</div>
									<input type="submit" value="Subscribe" name="subscribe" class="button subscribe-submit">
							</form>
						</div>
						
			</div><!-- .widget-inner-wrap /-->

			<div class="clearfix"></div></div><!-- .widget /-->					</div><!-- .tie-col /-->
				
				
			</div><!-- .tie-row /-->
		</div><!-- .footer-widget-area /-->

		
				</div><!-- .container /-->
			</div><!-- #Footer-widgets-container /-->
			
			<div id="site-info" class="site-info site-info-layout-2">
				<div class="container">
					<div class="tie-row">
						<div class="tie-col-md-12">

							<div class="copyright-text copyright-text-first">&copy; Copyright 2022, All Rights Reserved &nbsp;| <a href="https://plugtimes.com">PlugTimes.com</a></div><div class="copyright-text copyright-text-second">Powered by Ovicomm Network</div><ul class="social-icons"><li class="social-icons-item"><a class="social-link  rss-social-icon" title="RSS" rel="nofollow noopener" target="_blank" href="https://plugtimes.com/feed/"><span class="fa fa-rss"></span></a></li><li class="social-icons-item"><a class="social-link  facebook-social-icon" title="Facebook" rel="nofollow noopener" target="_blank" href="https://facebook.com/PlugTimesHQ"><span class="fa fa-facebook"></span></a></li><li class="social-icons-item"><a class="social-link  twitter-social-icon" title="Twitter" rel="nofollow noopener" target="_blank" href="https://twitter.com/PlugTimesHQ"><span class="fa fa-twitter"></span></a></li><li class="social-icons-item"><a class="social-link  youtube-social-icon" title="YouTube" rel="nofollow noopener" target="_blank" href="https://www.youtube.com/channel/UCfzisG003ehwbPeat8eEROA"><span class="fa fa-youtube"></span></a></li><li class="social-icons-item"><a class="social-link  instagram-social-icon" title="Instagram" rel="nofollow noopener" target="_blank" href="https://instagram.com/PlugTimesHQ"><span class="fa fa-instagram"></span></a></li></ul> 

						</div><!-- .tie-col /-->
					</div><!-- .tie-row /-->
				</div><!-- .container /-->
			</div><!-- #site-info /-->
			
</footer><!-- #footer /-->


		<a id="go-to-top" class="go-to-top-button" href="#go-to-tie-body">
			<span class="fa fa-angle-up"></span>
			<span class="screen-reader-text">Back to top button</span>
		</a>
		<div class="clear"></div>
	
		</div><!-- #tie-wrapper /-->

		

	<aside class="side-aside normal-side tie-aside-effect dark-skin dark-widgetized-area is-fullwidth" aria-label="Secondary Sidebar">
		<div data-height="100%" class="side-aside-wrapper has-custom-scroll">

			<a href="#" class="close-side-aside remove big-btn light-btn">
				<span class="screen-reader-text">Close</span>
			</a><!-- .close-side-aside /-->

			<div id="mobile-container">

				
				<div id="mobile-menu" class=" has-custom-menu">

					<div class="menu-main-menu-container"><ul id="mobile-custom-menu" class="menu" role="menubar"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-26"><a href="https://plugtimes.com">HOME</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6904"><a href="https://plugtimes.com/news/">NEWS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22 tie-current-menu"><a href="https://plugtimes.com/entertainment/">ENTERTAINMENT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16683"><a href="https://plugtimes.com/business/">BUSINESS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://plugtimes.com/sports/">SPORTS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25"><a href="https://plugtimes.com/technology/">TECHNOLOGY</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5586"><a href="https://plugtimes.com/editorials/">EDITORIALS</a></li>
</ul></div>
				</div><!-- #mobile-menu /-->

				<div class="mobile-social-search">
											<div id="mobile-social-icons" class="social-icons-widget solid-social-icons">
							<ul><li class="social-icons-item"><a class="social-link  rss-social-icon" title="RSS" rel="nofollow noopener" target="_blank" href="https://plugtimes.com/feed/"><span class="fa fa-rss"></span></a></li><li class="social-icons-item"><a class="social-link  facebook-social-icon" title="Facebook" rel="nofollow noopener" target="_blank" href="https://facebook.com/PlugTimesHQ"><span class="fa fa-facebook"></span></a></li><li class="social-icons-item"><a class="social-link  twitter-social-icon" title="Twitter" rel="nofollow noopener" target="_blank" href="https://twitter.com/PlugTimesHQ"><span class="fa fa-twitter"></span></a></li><li class="social-icons-item"><a class="social-link  youtube-social-icon" title="YouTube" rel="nofollow noopener" target="_blank" href="https://www.youtube.com/channel/UCfzisG003ehwbPeat8eEROA"><span class="fa fa-youtube"></span></a></li><li class="social-icons-item"><a class="social-link  instagram-social-icon" title="Instagram" rel="nofollow noopener" target="_blank" href="https://instagram.com/PlugTimesHQ"><span class="fa fa-instagram"></span></a></li></ul> 
						</div><!-- #mobile-social-icons /-->
												<div id="mobile-search">
							<form role="search" method="get" class="search-form" action="https://plugtimes.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</div><!-- #mobile-search /-->
										</div><!-- #mobile-social-search /-->

			</div><!-- #mobile-container /-->


			
				<div id="slide-sidebar-widgets">
					<div id="top-posts-3" class="container-wrapper widget widget_top-posts"><div class="widget-title the-global-title"><h4>Trending Now<span class="widget-title-icon fa"></span></h4></div><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://plugtimes.com/2022/03/3-music-awards-2022-winners/" title="3 Music Awards 2022 Winners | See Full List" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/3-music-awards-2022-winners.jpg?fit=796%2C453&#038;ssl=1&#038;resize=40%2C40" alt="3 Music Awards 2022 Winners | See Full List" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://plugtimes.com/2022/03/3-music-awards-2022-winners/" title="3 Music Awards 2022 Winners | See Full List" class="bump-view" data-bump-view="tp">3 Music Awards 2022 Winners | See Full List</a>
							</div>
													</li>
											<li>
						<a href="https://plugtimes.com/2022/03/watch-live-3-music-awards-2022-ceremony/" title="WATCH LIVE: 3 Music Awards 2022 Ceremony" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/3-music-awards-2022.jpg?fit=766%2C381&#038;ssl=1&#038;resize=40%2C40" alt="WATCH LIVE: 3 Music Awards 2022 Ceremony" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://plugtimes.com/2022/03/watch-live-3-music-awards-2022-ceremony/" title="WATCH LIVE: 3 Music Awards 2022 Ceremony" class="bump-view" data-bump-view="tp">WATCH LIVE: 3 Music Awards 2022 Ceremony</a>
							</div>
													</li>
											<li>
						<a href="https://plugtimes.com/2022/03/kojo-jones-marries-rachael-osei-lavish-ceremony/" title="Kojo Jones marries Rachael Osei in Lavish Ceremony" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/Kojo-Jones-weds-Raychel-Ghana-Marriage-wedding.jpg?fit=1000%2C550&#038;ssl=1&#038;resize=40%2C40" alt="Kojo Jones marries Rachael Osei in Lavish Ceremony" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://plugtimes.com/2022/03/kojo-jones-marries-rachael-osei-lavish-ceremony/" title="Kojo Jones marries Rachael Osei in Lavish Ceremony" class="bump-view" data-bump-view="tp">Kojo Jones marries Rachael Osei in Lavish Ceremony</a>
							</div>
													</li>
											<li>
						<a href="https://plugtimes.com/2022/03/maame-serwaa-body-shamed-exposing-heavy-chest-video/" title="Maame Serwaa Body-shamed for Exposing her Heavy Chest - VIDEO" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2022/03/maame-serwaa-breast-wedding.jpg?fit=1000%2C550&#038;ssl=1&#038;resize=40%2C40" alt="Maame Serwaa Body-shamed for Exposing her Heavy Chest - VIDEO" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://plugtimes.com/2022/03/maame-serwaa-body-shamed-exposing-heavy-chest-video/" title="Maame Serwaa Body-shamed for Exposing her Heavy Chest - VIDEO" class="bump-view" data-bump-view="tp">Maame Serwaa Body-shamed for Exposing her Heavy Chest - VIDEO</a>
							</div>
													</li>
											<li>
						<a href="https://plugtimes.com/2021/07/tebogo-thobejane-swim-collections-photos/" title="Tebogo Thobejane; the Star of Swim-focus Collections - Latest Photos Prove" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="https://i0.wp.com/plugtimes.com/wp-content/uploads/2021/07/Tebogo-Thobejane.jpg?fit=1079%2C706&#038;ssl=1&#038;resize=40%2C40" alt="Tebogo Thobejane; the Star of Swim-focus Collections - Latest Photos Prove" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://plugtimes.com/2021/07/tebogo-thobejane-swim-collections-photos/" title="Tebogo Thobejane; the Star of Swim-focus Collections - Latest Photos Prove" class="bump-view" data-bump-view="tp">Tebogo Thobejane; the Star of Swim-focus Collections - Latest Photos Prove</a>
							</div>
													</li>
						</ul>
<div class="clearfix"></div></div><!-- .widget /-->				</div>
			
		</div><!-- .side-aside-wrapper /-->
	</aside><!-- .side-aside /-->

	
	</div><!-- #tie-container /-->
</div><!-- .background-overlay /-->

<!--googleoff: all--><div id="cookie-law-info-bar" data-nosnippet="true"><span>This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish.<a role='button' data-cli_action="accept" id="cookie_action_close_header" class="medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button">Accept</a> <a href="https://plugtimes.com/cookies-policy/" id="CONSTANT_OPEN_URL" target="_blank" class="medium cli-plugin-button cli-plugin-main-link">Read More</a></span></div><div id="cookie-law-info-again" data-nosnippet="true"><span id="cookie_hdr_showagain">Privacy &amp; Cookies Policy</span></div><div class="cli-modal" data-nosnippet="true" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
	<div class="cli-modal-content cli-bar-popup">
		  <button type="button" class="cli-modal-close" id="cliModalClose">
			<svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
			<span class="wt-cli-sr-only">Close</span>
		  </button>
		  <div class="cli-modal-body">
			<div class="cli-container-fluid cli-tab-container">
	<div class="cli-row">
		<div class="cli-col-12 cli-align-items-stretch cli-px-0">
			<div class="cli-privacy-overview">
				<h4>Privacy Overview</h4>				<div class="cli-privacy-content">
					<div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may affect your browsing experience.</div>
				</div>
				<a class="cli-privacy-readmore" aria-label="Show more" role="button" data-readmore-text="Show more" data-readless-text="Show less"></a>			</div>
		</div>
		<div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">
												<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab">
								Necessary							</a>
															<div class="wt-cli-necessary-checkbox">
									<input type="checkbox" class="cli-user-preference-checkbox"  id="wt-cli-checkbox-necessary" data-id="checkbox-necessary" checked="checked"  />
									<label class="form-check-label" for="wt-cli-checkbox-necessary">Necessary</label>
								</div>
								<span class="cli-necessary-caption">Always Enabled</span>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="necessary">
								<div class="wt-cli-cookie-description">
									Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.								</div>
							</div>
						</div>
					</div>
																	<div class="cli-tab-section">
						<div class="cli-tab-header">
							<a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="non-necessary" data-toggle="cli-toggle-tab">
								Non-necessary							</a>
															<div class="cli-switch">
									<input type="checkbox" id="wt-cli-checkbox-non-necessary" class="cli-user-preference-checkbox"  data-id="checkbox-non-necessary" checked='checked' />
									<label for="wt-cli-checkbox-non-necessary" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">Non-necessary</span></label>
								</div>
													</div>
						<div class="cli-tab-content">
							<div class="cli-tab-pane cli-fade" data-id="non-necessary">
								<div class="wt-cli-cookie-description">
									Any cookies that may not be particularly necessary for the website to function and is used specifically to collect user personal data via analytics, ads, other embedded contents are termed as non-necessary cookies. It is mandatory to procure user consent prior to running these cookies on your website.								</div>
							</div>
						</div>
					</div>
										</div>
	</div>
</div>
		  </div>
		  <div class="cli-modal-footer">
			<div class="wt-cli-element cli-container-fluid cli-tab-container">
				<div class="cli-row">
					<div class="cli-col-12 cli-align-items-stretch cli-px-0">
						<div class="cli-tab-footer wt-cli-privacy-overview-actions">
						
															<a id="wt-cli-privacy-save-btn" role="button" tabindex="0" data-cli-action="accept" class="wt-cli-privacy-btn cli_setting_save_button wt-cli-privacy-accept-btn cli-btn">SAVE &amp; ACCEPT</a>
													</div>
						
					</div>
				</div>
			</div>
		</div>
	</div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
<!--googleon: all--><div id="reading-position-indicator"></div><div id="fb-root"></div>	<div id="tie-popup-login" class="tie-popup">
		<a href="#" class="tie-btn-close remove big-btn light-btn">
			<span class="screen-reader-text">Close</span>
		</a>
		<div class="tie-popup-container">
			<div class="container-wrapper">
				<div class="widget login-widget">

					
					<div class="widget-title the-global-title">
						<h4>Log In <span class="widget-title-icon fa "></span>
						</h4>
					</div>

					<div class="widget-container">
						
			<div class="login-form">

				<form name="registerform" action="https://plugtimes.com/wp-login.php" method="post">
					<input type="text" name="log" title="Username" placeholder="Username">
					<div class="pass-container">
						<input type="password" name="pwd" title="Password" placeholder="Password">
						<a class="forget-text" href="https://plugtimes.com/wp-login.php?action=lostpassword&redirect_to=https%3A%2F%2Fplugtimes.com">Forget?</a>
					</div>

					<input type="hidden" name="redirect_to" value="/2022/03/morris-chestnut-star-hollywood-walk-of-fame/"/>
					<label for="rememberme" class="rememberme">
						<input id="rememberme" name="rememberme" type="checkbox" checked="checked" value="forever" /> Remember me					</label>

					
					
					<button type="submit" class="button fullwidth login-submit">Log In</button>

									</form>

				
			</div>
								</div><!-- .widget-container  /-->
				</div><!-- .login-widget  /-->
			</div><!-- .container-wrapper  /-->
		</div><!-- .tie-popup-container /-->
	</div><!-- .tie-popup /-->
					<div id="tie-popup-adblock" class="tie-popup is-fixed-popup">
					<div class="tie-popup-container">
						<div class="container-wrapper">
						<span class="fa fa-ban" aria-hidden="true"></span>
						<h2>Adblock Detected</h2>
						<div class="adblock-message">Please consider supporting us by disabling your ad blocker</div>
						</div><!-- .container-wrapper  /-->
					</div><!-- .tie-popup-container /-->
				</div><!-- .tie-popup /-->
				<script type='text/javascript' src='https://plugtimes.com/wp-content/themes/jannah/assets/js/advertisement.js'></script>
			<style>.wp-container-623ff1a13e754 .alignleft { float: left; margin-right: 2em; }.wp-container-623ff1a13e754 .alignright { float: right; margin-left: 2em; }</style>
<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"PlugTimesHQ"}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"AddThis","anonymous_profile_id":"wp-29ecaaee8b38e182fc0490e1a61145cc","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script><script type='text/javascript' defer src='https://c0.wp.com/p/jetpack/10.7/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' defer src='https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5d8978f18e6d500b' id='addthis_widget-js'></script>
<script type='text/javascript' defer src='https://plugtimes.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/intersection-observer.js?minify=false' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' defer src='https://plugtimes.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-lazy-images/dist/lazy-images.js?minify=false' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' defer src='https://plugtimes.com/wp-content/themes/jannah/assets/js/scripts.min.js' id='tie-scripts-js'></script>
<script type='text/javascript' id='tie-scripts-js-after'>
        var _foxpush = _foxpush || [];
        _foxpush.push(['_setDomain', 'PlugTimescom']);

        (function(){
            var foxscript = document.createElement('script');
            foxscript.src = '//cdn.foxpush.net/sdk/foxpush_SDK_min.js';
            foxscript.type = 'text/javascript';
            foxscript.async = 'true';
            var fox_s = document.getElementsByTagName('script')[0];
            fox_s.parentNode.insertBefore(foxscript, fox_s);})();
			
</script>
<script type='text/javascript' defer src='https://c0.wp.com/c/5.9.2/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js'></script>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=1323769234338022&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<script src='https://stats.wp.com/e-202212.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.7',blog:'152584347',post:'36592',tz:'0',srv:'plugtimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '152584347', '36592' ]);
</script>
</body>
</html>
